Page 3 of 3

Re: New member introduction

Posted: Sat May 05, 2018 3:07 pm
by Scalino
Well, it's weeping from the plug in the top of the filter housing (100% sure) on two carbs. We 'fixed' it by putting some fuel resistant Locktight on it. Is it a professional solution? Well no, but it works. We'll keep a very close eye on it, but for now it seems to work. Now, it may not have been much of a leak, but any fuel leak is too much in my eyes.

Now all throats are synchronised and the idle mixture set, it runs very well I would say, a massive improvement pre carb overhaul. :D

Slight bummer, the battery isn't charging, so we'll have a look at that now...

Re: New member introduction

Posted: Sun May 13, 2018 9:29 am
by Scalino
Well, I was an idiot :lol:. The plug with the yellow and grey wire wasn't plugged in. To my defence, one end is actually a plug, but on the other side they didn't bother to put the right connectors for a plug on, hence there is no plug on that end. Not a great description I know ;). Generally the wiring is just a mess, so it isn't immediately obvious when there is a loose connector... :|

Conclusion, all is working as it should, for now at least :roll:

Re: New member introduction

Posted: Wed Nov 21, 2018 7:57 pm
by Scalino
Long time no update, which is good news. It means we've just been enjoying by driving it instead of just wrenching for a change. I quite like this change, although the fuel gets quite expensive in comparison :lol:

What I have done a few months ago is give it a polish, which it badly needed. It's gone from orange to red :)

It actually looks quite presentable now (apart for the wheels, tires and roof...)


Let's see wether I can attach pictures...

It seems I can by attaching them :)